In response to the recent PCI compliance requirements, we would now like to ask you to let us know ASAP if your website needs to be on a PCI compliant server.

Need PCI Compliance? Read this and contact us ASAP...

If your website DOES need to be on a PCI compliant server, we will move it for you to a compliant server.

Either open a support ticket titled "PCI Compliant server required for domainname.co.uk" or simply give us a call and let us know when we can move it.

You should however be aware that the latest changes to PCI compliance are that any versions of TLS (Transport Layer Security) prior to version 1.2 now need to be disabled, which can cause problems with Windows 7 or previous versions of MacOS, due to these operating systems not having the required TLS compatibility.

PCI Compliance not needed?

If PCI compliance is not needed or not going to affect you, and you have the latest Windows 10 or MacOS, then you dont need to do anything.

If you are still using Windows 7 or an older MacOS and you suddenly find that you are now having email issues then please contact us ASAP as there is a very good chance that your email client or operating system is not able to work without the older versions of TLS (Transport Layer Security) and so we can move your website to a non-compliant server in a matter of minutes.

I have no idea what this means!

Dont worry, if you dont know what PCI compliance is or dont know if you need to be compliant then please ask us or your website payment provider.


Monday, April 30, 2018







« Back