Wordpress minimum security requirements

Dear all Important WordPress Notification - Please read ALL of this if using WordPress. Because of how awesome and popular WordPress is, we now need to insist that you MUST install and use the security plugin Wordfence. (With live traffic disabled) If you are using WordPress anywhere in your hosting plans, you MUST install and ... Read More »

14th Feb 2017