In line with PCI Compliance requirements, both SagePay and PayPal are requiring that older versions of TLS (Prior to v1.2) be disabled from the end of April.

Other payment providers will surely not be far behind them...

In response to this requirement, we appreciate the fact that not every customer needs to be PCI Compliant, and disabling older versions of TLS will cause software problems for people still using Windows 7 and older versions of MacOS, so in order to avoid causing problems for anybody not needing PCI compliance, we are offering several servers just for PCI compliance requirements.

We will be emailing you on a "per-server" basis shortly to find out if you need to be PCI compliant or not, and if not, we may need to move your website to a non-compliant server.

Please do look out for an update, by email shortly, and we are also posting updates on our Facebook page, Twitter, Linkedin too.

Tuesday, April 24, 2018







« Back